1592990 - StreamWork Enterprise Agent install fails

SAP Knowledge Base Articles - public

1592990 - StreamWork Enterprise Agent install fails


During the StreamWork Enterprise Agent Configuration step of
installation, we receive the message ERROR: failed to logon to cms

Reproducing the Issue

During the installation of the Streamwork Enterprise Agent,  it is beneficial to examine logs or run in Dembug Mode.

  1. Select debug mode in the boot menu at the very beginning of the install. This will pause the installer at various points, but it
    also gives an interactive text console for debugging.
  2. At the point where you receive the error, you can select "control-alt-windows-F2" to switch out of the graphical installer to the
    debug console. (You can select "control-alt-windows-F7" to go back to the graphical console at any time).
  3. Once in the debug console, you should be able to access the log files directly. The setup logs will be under /opt/sap/installers/
    sbop-cstarentsetup-1.0.2/setup/log. The system logs will be under /var/preserve/sap/logging.


The connection to the CMS is not occuring because the system has not completely stopped before continuing to restart.  It has been found that the connection is attempting to be made before the system has been able to be restarted.


Corrective actions to the installation scripts have been made to allow the system to com[pletely shutdown before the restart is attempted.  This issue should no longer present a problem.

In the unlikely event that the error reoccurs,  a manual start of the CMS can be made using the scripts in the bin directory.


KBA , BI-OD-SEA , SAP StreamWork enterprise agent , Problem


enterprise agent for SAP StreamWork all versions