SAP Knowledge Base Article - Public

1533348 - Prompted multiple times to log on BusinessObjects Enterprise Repository when opening a report in Crystal Reports

Symptom

  • Prompted multiple times to log on BusinessObjects Enterprise Repository when opening a report in Crystal Reports
  • In Crystal Reports 2008, when opening a report that contains subreports based off Business Views, it prompts to login to BusinessObjects Enterprise repository for each Business View connection.
  • When opening the same report in Crystal Reports XI R2, it only prompt once to log on BusinessObjects Enterprise Repository

Environment

  • Crystal Reports 2008
  • BusinessObjects Enterprise XI 3.1

Reproducing the Issue

  1. In Crystal Reports 2008, create a report based off a Business View
  2. Insert 2 or more subreports based off a Business View coming from the same BusinessObjects Enterprise Respository
  3. Save the report to your local computer
  4. Close Crystal Reports 2008
  5. Open Crystal Reports 2008, and open the report you just saved to your local drive
  6. You will be prompted to login to BusinessObjects Enterprise for each Business View connection.

Example:

If the main report is based off Business View A, and 2 subreports are based off BusinessView B, you will then be prompted 3 times to connect to BusinessObjects Enterprise.  Once for the main report, and twice for the subreports.

In Crystal Reports XI R2 and below, it will only prompt once to connect to BusinessObjects Enterprise repository.

Cause

  • The issue has been identified and logged under Problem Report ID ADAPT01465885

Resolution

  • The issue has been resolved in Fix Pack 3.3 of Crystal Reports 2008

Keywords

Crystal Reports 2008, CR, Business Views, prompts, subreports , KBA , BI-RA-CR , Crystal Reports designer or BusinessViews Manager , Problem

Product

Crystal Reports 2008 V0