SAP Knowledge Base Article - Public

1457681 - Running Total not returning the correct value in Crystal Reports

Symptom

Running total returns 0 even if the evaluate conditions are not satisfied. Ideally it should return NULL till the evaluation condition is satisfied next time.

Environment

Crystal Reports XI Release 2

Crystal Reports 2008 Service Pack 1

Reproducing the Issue

  1. Create a Crystal Report based on some data which contains a field with some NULL values.
  2. Create Running total based on this field.
  3. Place the Running Total in details section and observe the behavior.

Note:

  • When condition is satisfied for the first time the running total gets evaluated and the correct value is returned.
  • For the next record if the condition is not satisfied the running total is not evaluated and nothing is returned
    and it shows NULL.
  • Next time when the condition is satisfied the running total gets evaluated and this time it returns 0 and that is correct value as database field which is getting evaluated contains 0 for that instance. Problem occurs from here onwards.For each next occurrence of the running total it returns 0 even if the evaluate conditions is not satisfied.
  • Cause

    The issue has been identified as a potential bug and reported to Porduct Group under reference number ADAPT01165268

    Resolution

    Apply Service Pack 6 for Crystal Reports XI R2.

    Apply Service Pack 3 for Crystal Reports 2008.

    Keywords

    running sum , KBA , BI-RA-CR , Crystal Reports designer or BusinessViews Manager , Bug Filed

    Product

    Crystal Reports 2008 V1 ; SAP Crystal Reports XI R2