1435346 - Wrong SQL and data return in Webintelligence query when condition is applied on a @aggregate_aware object

SAP Knowledge Base Article - Public

1435346 - Wrong SQL and data return in Webintelligence query when condition is applied on a @aggregate_aware object

Symptom

  • When aggregate_aware object is used in query condition the SQL does not point to the correct table anymore

Environment

  • Business Objects XI 3.x

Reproducing the Issue

  1. Create an aggregate_aware table in database
  2. Create a connection pointing to this Database
  3. Save the universe
  4. In deskI create a report using <Country>,<Month>, and <Quantity> object
  5. Put a condition <Quantity> > 50 -> check the SQL
  6. Run the query
  7. Activate the drill and drill down from Country to City -> data is returned
  8. Create the same query in WebI
  9. Drill down -> no data is return empty table

NB : If you check the SQL it is pointing to the year table and not anymore to the Month table

Cause

This has been logged as a product defect : Bug # ADAPT01368237

Resolution

The issue is currently under investigation by Product Group and is schedule to be addressed in Fix Pack 2.7 of BOXI 3.x.Please note that this is subject to change as the investigation is in progress. When the service pack is releaased, please refer to its ReadMe file to check if it includes the mentioned ADAPT

Keywords

BOXI 3.x, wrong, not correct, , KBA , BI-RA-WBI , Web Intelligence , Bug Filed

Product

Crystal Reports 2008 V1