1416806 - XLST tranform fail using CR job server

SAP Knowledge Base Articles - public

1416806 - XLST tranform fail using CR job server


  • When using a custom XLST tranform fails using CR job server when there is sub report
  • The problem is when scheduling the job runs successfully but the file output is empty
  • Clicking on the job instance you get the following error:
XML Parsing Error: no element found Location:http://localhost:8080/PlatformServices/content/view.do? service=%2FCmcApp%2FApp% 2FappService.jsp&containerId=14819&loc=en&objIds=
14994&actId=257&appKind=CMC&pref=maxOpageU%3D%3BmaxOpageUt%3D200%3BmaxOpageC%3D%3Bt z%3DAmerica%2FLos_Angeles%3BmUnit%3D%3BshowFilt
ers%3Dtrue%3BsmtpFrom%3Dtrue% 3BpromptForUnsavedData%3Dfalse% 3B&pvl=en_US&showApply=true&cafWebSesInit=true&bttokents=12602176690
62&bttoken=000DB1gU5o9kNIPb5%5BV%5E0loBISSXGo%3E0 Line Number 1, Column 1: ^ 

Reproducing the Issue

  1. Publish a report with a subreport to Enterprise. 
  2. Use a custom XML in the Export options for XML. Make sure it is on the Processing server in the expected location. 
  3. Schedule the report.
  4. Attempt to view the “Successful” instance – error appears.
  5. Find the instance on the FRS, notice it is totally empty.
  6. Open the report in CR designer and remove the subreports.
  7. Export the report without subreports to Enterprise.
  8. The issue no longer occurs.


This is a known issue and ADAPT01340148 has been created for this.


It will be fixed in SP3


ADAPT01340148; ADAPT 01340148; 01340148 , KBA , BI-BIP-ADM , BI Servers, security & CrystalReports viewing in BI platform , Problem


Crystal Reports 2008 V0