SAP Knowledge Base Article - Public

1381920 - Unable to download Crystal Reports

Symptom

  • Error: 'You are not authorized' when attempting to download Crystal Reports; or
  • When attempting to download Crystal Reports, nothing happen; or
  • Cannot see Crystal Reports downloads from the SAP Support website.
  • Followed the steps on how to download Crystal Reports from SAP Knowledge Base , but still cannot see the download, or it generates an error.

Environment

  • SAP Crystal Reports 2008
  • SAP Crystal Reports 2011
  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016

Reproducing the Issue

  1. In a web browser, go to the SAP Support Portal at: https://support.sap.com
  2. Select "Download Software"
  3. In the SAP One Support Launchpad, unable to find Crystal Reports downloads, or it is available, but it fails to download.

Cause

  • There are many reasons why the download of a product is not available, or fails to download. For example it could be because:
    • No license for the software were purchased, and therefore no download is available; or
    • The user account does not have rights to see the download; or
    • The software was purchased from a re-seller, and therefore the software is not available to download from the SAP Product Download; or
    • There is an issue with the SAP Product Download website, that causes the download to fails; or
    • There is a network, or slow internet connection causing the download to fail.

Resolution

  • Confirm you have rights to download software on the SAP Support Portal:
    • Contact your company Super Administrator to ensure your S-User name have been authorized to download software.
                   
  • If you have purchased a license for Crystal Reports from SAP, and the software is not available, then:
    • Create an incident on the SAP Support website under the component: XX-SER-SAPSMP-SWC
             
  • If you have purchased the product from a re-seller, then:
    • contact the re-seller for a download link.
             
  • If you have not purchased the product, then:
    • Contact SAP Sales representative to purchase the product.
             
  • In any scenarios, as a temporary solution you can:
       
    • Download a trial copy of latest version of Crystal Reports from: 
            
           https://www.sap.com/canada/products/crystal-reports.html
              
      And click on the "Try" button on the upper right corner, to download a full copy of Crystal Reports, and use your permanant keycode to install it, or if you do not have it yet, use the temporary keycode that will be sent to you.
                 
               
    • If required, download product updates from the Crystal Reports Downloads public website at:   
       
           https://websmp130.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/patch_download/main_public.htm
          

Keywords

CR, downlaod , KBA , XX-SER-SAPSMP-SWC , SAP Support Portal - Software Distribution Center , BI-RA-CR , Crystal Reports designer or BusinessViews Manager , Problem

Product

Crystal Reports 2008 V1 ; SAP Crystal Reports 2011 ; SAP Crystal Reports 2013 ; SAP Crystal Reports 2016