1298020 - OLAP Grid in Crystal Reports 2008 displays incorrect values

SAP Knowledge Base Articles - public

1298020 - OLAP Grid in Crystal Reports 2008 displays incorrect values


  • OLAP report in Crystal Reports 2008 based on Mircosoft Analysis Service 2005 OLAP cube displays values in the OLAP Grid incorrectly.
  • The OLAP Grid displays '0' or NULL, but in the 'cube view page' the correct data is visible.

Reproducing the Issue

  1. Use a Microsoft Analysis Server 2005 cube.
  2. Create a Crystal Reports 2008 report based on that OLAP cube.
  3. Once the OLAP Grid is displayed you will see '0' valus in the grid.
  4. Right click in the OLAP Grid and select 'View Cube'.
  5. You get to the 'Cube View' page. The correct values are displayed.
  • Crystal Reports 2008 Version 0
  • Crystal Reports 2008 Version 1
  • Microsoft Analysis Services 2005 (SP1 and SP2)
  • All Micosoft Windows systems that are supported by Crystal Reports 2008.
  • Cause

    • The reason for this problem is that certain data types from Mircosoft Analysis Services 2005 are not correctly transferred to the Crystal Reports 2008 report.
    • The problematic data types in Microsoft Analysis Services 2005 are the following:
    1. BigInt
    2. Single
    3. UnsignedInt
    •  The issue has been escalation under ADAPT01160285.


    • The issue has been escalated and the fix will be part of FixPack 1.3 for Business Objects Enterprise 3.1.
    • FixPack 2.3 is scheduled to be released Mid February 2009.
    • It also will be part of Service Pack 2 for Business Objects Enterprise 3.1 to be released end of May.


    OLAP, MSAS 2005, cube, CR 2008, BOE 3.1, FP 1.3, SP2 , KBA , BI-RA-CR , Crystal Reports designer or BusinessViews Manager , Problem


    Crystal Reports 2008 V0 ; Crystal Reports 2008 V1