1290002 - How to import a Flash file generated via Xcelsius in Crystal Reports designer 2008

SAP Knowledge Base Article - Public

1290002 - How to import a Flash file generated via Xcelsius in Crystal Reports designer 2008

Symptom

This article explains how to import a Xcelsius document in Crystal Reports 2008.

Environment

  • Xcelsius 2008
  • Crystal reports Designer 2008

Resolution

  1. Launch Crystal Reports Designer
  2. Create a report at least one dimension and one measure
  3. Launch Xcelsius
  4. Go to Data -> Connections
  5. Add a 'Crystal Report Data Consumer' connection
  6. Bind respectively the row headers or/and column headers and data to cell range in Excel
  7. Place a spreadsheet table in order to display the data
  8. Save the dashboard
  9. Go to File -> Export -> Flash
  10. Launch Crystal reports designer
  11. Go to Insert -> Flash
  12. Browse to the exported SWF file and select the 'Link' option
  13. Place the object either in the report header or report footer section
  14. Right-click on the Flash object and choose 'Flash Data expert'
  15. in the 'Xcelsius data' tab, Bind crystal reports data to the Xcelsius component
  16. click OK
  17. Switch to Preview

==> The data should be reflected in the Flash file.

Keywords

import bring importing Xcelsius document in crystal reports designer SWF .swf retrieve refresh report crosstab cross-tab , KBA , BI-RA-XL , Dashboards and Presentation Design , How To

Product

Crystal Reports 2008 V0 ; SAP BusinessObjects Xcelsius Enterprise 2008