SAP Knowledge Base Article - Public

1218730 - Sorting ignored in Btrieve report with 'Use Indexes or Server for Speed' enabled

Symptom

After selecting the 'Use Indexes or Server for Speed' option in Crystal Reports 10, sort settings are ignored in native Btrieve reports.

Cause

The issue has been identified and tracked under ID ADAPT00435671.

Resolution

Hot Fixes or Service Packs address this issue as indicated below. This behavior is by design. When the 'Use Indexes or Server for Speed' option is enabled, the sorting role is passed to the server. Due to limitations in the native Btrieve driver, more than one index cannot be accessed for the same request. As a result, sorting is incorrectly applied.

With the update(s), the following registry entry key is added to resolve this issue:

Registry Entry Information

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Subkey: HKEY_CURRENT_USER\Software\Crystal Decisions\10.0\Crystal Reports\Database\Btrieve\DoNotPushDownSorting

Type: STRING

Recognized Values: Yes; No

Default Value: No

Creation Method: Hot Fix Installation

When this entry is set to "Yes", the sort settings are evaluated and applied to the report.

Unless indicated otherwise, Weekly Hot Fix updates from the FTP site have only been tested with English versions of our products.

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CAUTION:

Hot Fixes and Service Packs are not designed for OEM versions. Do not apply these updates if you are using an OEM version. To determine if you are using an OEM version, refer to the OEM Product Warning.

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Crystal Reports 10

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For Crystal Reports 10, the latest update for this issue is available on the Downloads area of our web site.

This issue is addressed in the following components (and later versions):

  • p2bbtrv.dll, version 10.0.5.19, dated 6/10/2005

 

Monthly Hot Fixes and Service Packs

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Monthly Hot Fixes readmes and Service Pack readmes are available in the Downloads area of our web site.

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NOTE:

Issues addressed on one operating system platform at the Weekly Hot Fix level may be addressed later on multiple operating system platforms (if applicable) at the Monthly Hot Fix and Service Packs level. For example, an issue only resolved on the Windows platform in a Weekly Hot Fix may be resolved later on UNIX platforms such as IBM AIX and Sun Solaris in future Monthly Hot Fixes or Service Packs for these platforms.

To determine if these issues are resolved in a Monthly Hot Fix or Service Pack on another platform, search for the Track ID number in the readme at the locations indicated above.

See Also

For more information on the issues addressed in the Hot Fix or Service Pack, view the readme PDF or text file included in the ZIP or TAR file.

For more information on the different update types, refer to our Hot Fix and Service Pack FAQ.

Keywords

CR CE WHF 435671 SORT B-TRIEVE DOES NOT WORK SORTED RECORDS FUNCTION FAILS Crystal Reports Btrieve Database Sorting Records , c2017831 , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed

Product

SAP Crystal Reports 10.0