SAP Knowledge Base Article - Public

3389485 - Error "Cannot invoke "com.jobs2web.common.util.TokenRequest.toString()" because "tokenRequest" is null" in the Recruiter Sync - Recruiting Marketing

Symptom

When accessing the Export Automated Process Logs in Command Center, the following error is displayed in the Recruiter Sync logs:

 "Cannot invoke "com.jobs2web.common.util.TokenRequest.toString()" because "tokenRequest" is null"

Environment

SAP SuccessFactors Recruiting Marketing

Reproducing the Issue

  1. Access Command Center
  2. Access Export Automated Process Logs
  3. Open the file
  4. In the Recruiter from ATS section you will see the error

Cause

This happens because the Company Id or Deployment Data Center is configured incorrectly in Career Site Builder.

Resolution

Please correct the Company Id or Deployment Data Center fields on Career Site Builder > Settings > Site Configuration > Site Integration tab.

After performing the above change, click on the Execute Now button.

Keywords

error, recruiter sync, export automated process logs, rmk, error recruiter sync, csb error , KBA , LOD-SF-RMK-ADM , Administration, Setting, Permissoin & RBP, RecruiterSyn , Problem

Product

SAP SuccessFactors Recruiting all versions