Symptom
- You are using the Live Activity and configured it to open the customer hub when a call arrives
- The expectation is that the Customer Hub window will open, but that does not happen with the inbound call
- However, the Customer Hub window opens when making an outbound call
Environment
SAP Cloud for Customer
Reproducing the Issue
- Place a call or simulate a call
- Widget opens up
- Confirm the customer/contact
- Customer Hub does not open
Cause
One possible cause is a mismatch on the Comm System ID maintained on Live Activity Configuration.
Resolution
- For an activity to be created when a phone call is accepted, your widget integration must have a Comm. System ID defined
- Go to Administrator
- Click "Service and Social"
- Navigate to and client on "Live Activity Configuration"
- See under Fiori Client Settings, and enter a value in the "Comm. System ID" field. For example, "Contact_Center".
- If you are accepting a Whatsapp message, check if an Activity is created under Activities - Messaging
If Activity is not created, recheck your scoping question:
- The Comm. System ID can then be maintained under the "Communication Systems" using the following steps:
- Go to the Administrator work center
- Select the General Settings view
- Open Communication Systems
- If there was no Comm. System ID, then create a one
- Click "New"
- Under "Basic Information", enter the "ID" (for example, Contact_Center), "Host Name = Contact_Center" and "System Type = Internet"
- Go to System Instances and click "Add Row"
- Enter System ID = Contact_Center and Preferred Application Protocol = 5 - Web Service
- Click "Save and Close"
- If there was already one created, then ensure the ID is exactly the same as what was defined in the Live Activity Configuration AND "In Use" field is enabled
- Specially the System Instance ID, which in this example is "Contact_Center"
- It is important that both the Communication System ID and the Business Instance ID are the same as the one maintained on the Live Activity Configuration
See Also
Keywords
CTI ; live activity ; inbound call ; outbound call ; activity ; customer hub ; opened ; opening whatsapp ; message , KBA , LOD-CRM-LA , Live Activity , How To
Product
SAP Cloud for Customer core applications all versions