SAP Knowledge Base Article - Public

3232862 - Issue with date fields in the Create/Plan Customer Projects apps - SAP S/4HANA Cloud 2208

Symptom

After saving billing data including a billing item and billing item details (billing due dates), the Plan Customer Projects app shows a different date (shifted by one day) for the following fields:

  • Customer Reference Date
  • Billing Due Date
  • Service Start Date
  • Service End Date

Environment

SAP S/4HANA Cloud 2208 HFC2

Reproducing the Issue

  1. Open the Create Customer Projects or the Plan Customer Projects app
  2. Create a new customer project
  3. Navigate to the Billing area
  4. Maintain a value for Customer Reference Date
  5. Add a billing item, for example of type Periodic Service
  6. In the item details, maintain a billing due date
  7. Navigate back
  8. Save the project (and implicitly the related sales order)

Cause

Since SAP S/4HANA Cloud 2208, the sap.m.DatePicker also considers the time zone that is maintained in the settings.

Resolution

The issue is planned to be fixed with HFC3 (RTH 17.08.2022).

In order to prevent the issue, you need to have the system/browser and Fiori Launchpad time zone settings aligned.

See Also

KBA 3231384 - Chosen date in Date Picker is shifted
KBA 3232277 - Issue with Billing Date field in billing Fiori apps - SAP S/4HANA Cloud 2208
KBA 3232892 - Issue with Valid From and Valid To date in the Manage Product Hierarchy Assignments app - SAP S/4HANA Cloud 2208 
SAP Help - Plan Customer Projects
SAP Fiori Apps Library - Plan Customer Projects

Keywords

Plan Customer Projects; F0719; Dates; Date Picker; Customer Reference Date; Billing Due Date; Service Start Date; Service End Date; Time Zone; User Settings; Regression; CE2208 , KBA , SD-SLS-PBS , Project-Based Services in Sales Documents , Problem

Product

SAP S/4HANA Cloud 2208