Symptom
- Draft e-mail or note data would be lost when a new inbound CTI interaction arrives to the Live Activity or Agent Desktop
- Incoming causes e-mail draft from case disappear
Environment
- SAP Cloud for Customer
- SAP Cloud for Service
- SAP Cloud for Sales
Reproducing the Issue
- Agent is working on an existing ticket and is writing an e-mail or adding some notes
- An inbound interaction (Phone Call, e-mail, Chat or SMS) arrives
- The UI refreshes and take the Agent to the Live Activity or Agent Desktop
- The Agent navigates back to the previous screen, but notices that the text previously written has disappeared
Cause
- Interaction roundtrip causes the lost of focus (Live Activity)
- Currently there is no "auto-save" feature available for drafts
Resolution
- There are two options:
- Option 1: Enable the "TinyMCE Editor"
- Go to "Administrator" -> "Service and Social" -> Ticket Configuration -> Fiori Interactions
- Select the slider "Enable TinyMCE Editor"
- This will replace the RTE Editor/Buil-in Editor
- Only used in Internal memo, Portal memo and E-mails
- Option 2: Disable the "Open details Automatically for Incoming communication"
- Go to: "Administrator" > "Service and Social" > "Communication Channels" > "Live Activity Configuration"
- Uncheck the "Open details Automatically for Incoming communication"
- The above setting, the Agent will still get a notification of the unique caller; but the live activity center will not be automatically opened, hence allowing the Agent time to save the draft
- However, if the flag is required, please note that the system behavior is correct since the live activity center should be opened in a new tab, and when you switch tabs, the latest content is shown on the e-mail screen as there is no auto-save of e-mail.
- Please note that this will work only for cases related to e-mails and internal notes, not for ticket description, as outlined in KBA 3204112
See Also
3204112 - Text in description field within a ticket gets deleted once an inbound Live Activity interaction arrives
Keywords
Loss data, lost draft, e-mail, incoming, phone call, Auto-Save draft, Note, data loss , KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer core applications 2202