Symptom
You are using the "Password forgotten" feature on the logon Screen, but after you enter your details, no mail arrives.
Environment
- SAP Business ByDesign
- SAP Cloud for Customer
Reproducing the Issue
- On the Logon screen click "Forgot your Password?"
- Maintain your business user e-mail address
- You are waiting for the e-mail with your temporary password but do not receive it.
Cause
You have set in the e-mail and fax settings in the Business configuration "Send all emails to xxxx@XXX.com" ('xxxx@XXX.com' represents the relevant e-mail address - with this setting, all e-mails sent out by the system get sent only to this address). This is usually used for testing in Test Tenants; E-Mail and Fax Delivery in a Non-Productive System
The current system is a non-productive system. In a non-productive system you can specify whether e-mails and faxes should be sent to real addresses of business partners or to an address used for testing purposes.
As a password mail is not a business document nor is the Business User a business Partner, for security reasons SAP will not send any user related passwords to this e-mail.
Resolution
Key users should test in test environments. If you want to use this password forgotten feature in a test environment, ensure you do not assign a centralized e-mail address in that Test system (the "Send all e-mails to" option cannot be in use for the 'Password Forgotten' feature to be used).
Please proceed as follows and change to send all e-mails to Business Partners.
- Go to Business Configuration work center.
- Select Implementation Projects view or Overview.
- Search and Open the activity E-Mail and Fax Settings.
- Select E-Mail and Fax Settings.
- In the section E-Mail and Fax Delivery in a Non-Productive System, you have chosen Send all e-mails to Business Partners.
See Also
KBA 3121543 - Password forgotten function does not work
Keywords
Password forgotten, Password , e-mail , KBA , AP-RC-OUT , Output Management , LOD-CRM-ADM , Administration UI , How To