SAP Knowledge Base Article - Public

3096103 - Missing Surveys on Visits

Symptom

Surveys from active Activity Plans are not getting generated for some visits/ are not getting generated for visits every time.

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisites: you have valid and active activities (tasks, surveys), activity plans and routing rules in your system. As per the conditions you expect that they should be triggered for the account&visit in your particular scenario.

However, the activities do not get triggered for some of the created visits. 

Cause

The Activity plan(s) are marked for Frequency = once.

For a task or survey to be used in visits, you must clarify the Frequency. Choosing 'Always' allows the task to be generated in every applicable visit. Choosing 'Once' allows the task or survey to be generated only until is completed for that particular account.

Special Scenario:

An activity plan AP1 (AP1 represents the activity plan name) is created with a particular validity. For example validity: 1st -30th June 2021.  In June, visits are created and a task or survey from this activity plan was determined for one of the visits and the task executed or the survey was filled.

Later, the validity of this activity plan is changed to a later validity range, for example: 1st-30th September 2021. New visits are created in September. The Survey will not be determined. This is because the system still considers the task or survey in this activity as already executed/filled (as it was in June).

Resolution

This is the expected system behaviour as designed. If you wish for activities from an activity plan to be executed every time a visit happens, no matter if this was already executed during the last visit, please do not set the frequency as once.

Special Scenario:

  • Solution 1: When you update the validity of activity plan to September, please also delete the survey from activity plan and add it again. This will technically make it a NEW activity plan item.
  • Solution 2: Instead of changing and updating the same activity plan, create a new activity plan for the new validity period.

See Also

SAP Help Portal: Create Activity Plans (see Note: What happens when you define a frequency of once?)

Keywords

valid, mandatory, assign automatically, missing, empty, none , KBA , frequency , LOD-CRM-ACT-VST , Visit Planning , How To

Product

SAP Cloud for Customer core applications 2108