Symptom
- A user is taking content and is logged out of the application.
- A user has completed content, attempts to navigate or access another part of the application, and is logged out.
- The user is presented with the following error: "There is no valid user session or the session has timed out. Please login again."
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Cause
There are two common reasons:
- The timeout settings on the system have been modified
- The content is coded to send a logout command which invalidates the user session
Resolution
Check the timeout settings:
- Navigate to System Administration > Configuration > System Configuration
- Edit LMS_ADMIN
- Make sure that contentStructurePageKeepAliveInterval is set to 300 as per the default values. Do not increase this value.
Check the data sent by the content:
- Gather network traces while completing the content. Example on how to gather network traces can be seen here.
- Look for the PwsAicc or SCORMRteServlet API communications in the logs and find the LESSON_STATUS sent
- If the LESSON_STATUS has a 'logout' command, the content needs to be fixed. This is noted here
Note: Content troubleshooting is outside the scope of SAP Support as it's developed by 3rd party applications. Please contact your content developer/provider to update the content.
Keywords
KBA , LOD-SF-LMS-CNT , Content , Problem
Product
SAP SuccessFactors Learning all versions
Attachments
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