Symptom
Reports based on the data sources "Ticket Time Points and Contact Party" or "Ticket" show no descriptions in "Service Category" when logged on in a certain language. In another language, the descriptions are shown.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open your report from the Business Analytics or the Analysis work center.
- Check fields such as Serice Category, Cause Category, Incident Category etc. Display as ID and description.
- Note that it shows the category ID instead of the description.
You may notice that if you logon in another language, the description is shown correctly.
Cause
If the same category is maintained several times (same ID in different catalog versions), the category is not unique. The system does now know which category description to read, and usually reverts to the first one that was ever maintained for the category - usually this is in the catalog version 1. However, the category version that is selected can also be random.
If a description was not maintained in your language in the catalog version 1 or another version, no description is shown.
Resolution
Unfortunately this is currently a system restriction in those cases where categories are re-used across catalog versions. A short-term adjustment will not be possible, however you could register this as an enhancement request on the forums (https://influence.sap.com/sap/ino/#/campaign/1867).
For consistency in reporting, we would also recommend to ensure that category IDs are unique.
Keywords
analytics, reports, ticket, all tickets, service category catalog, description missing, translation missing, object category, service category, cause category, incident category , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Product Enhancement