SAP Knowledge Base Article - Public

3011069 - Checkpoints: Import and Export Job for SAC model via SAP BPC connection type

Symptom

  1. User is using SAP BPC connection in SAC Tenant to import or export BPC data. 
    Using Import Data - SAP BPC connection in SAC Tenant:
    1. Connection Type: SAP BPC: 
      1. Sub Type: SAP BPC for SAP BW/4HANA
      2. Sub Type: SAP BPC 10.1 for SAP NetWeaver
         
  2. User gets following issue: 
    1. Data is not synchronized between BPC and SAP Analytics Cloud (SAC) models.
    2. The import or export jobs failed with an error in SAC. 
    3. No data is imported.[Or It works for some periods and not works for some periods]
    4. Master data is imported but no transaction data imported. 
    5. THe wrong data is exported.
    6. "Error obtaining concurrency lock (foreign_lock)"
    7. "Error obtaining concurrency lock (enqueue_server_busy)"
    8. "BPC plugin error: read fact data with new json format ends in exception from BPC!"
    9. HTTP 400 EPM_SERVICE "Unable to retrieve the external data due to: EPM_SERVICE"
    10. "An internal server error occurred in Data Acquisition service" 
    11. PLUGIN_EXECUTION_ERROR
    12. Failed to execute client request
    13. HTTP 204 
    14. BPC plugin error
    15. An internal server error occurred in the Data Acquisition Service
    16. PLUGIN_EXECUTION_ERROR Failed to execute client request
    17. UJHANA_ERROR_004 Call TREX_EXT_AGGREGATE failed with 9300-: string too large
    18. Concurrency Lock
    19. rejection log download limitation
       
  3. For other connection type, please visit:
    1. Odata Service: 3220729 - Checkpoints: Import and Export Job for SAC model via OData Services
    2. S4HANA: 3220268 - Checkpoints: Import and Export Job for SAC model via S/4HANA connection
    3. IBP: 3242995 - Checkpoints: Export Job for SAC model via IBP [SAP Integrated Business Planning] connection
    4. DataSphere: 3304951 - Checkpoints: Data Integration Between SAP Analytics Cloud (SAC) Data and SAP Datasphere (DS)

Environment

  • SAP Business Planning and Consolidation, version for SAP NetWeaver
  • SAP Business Planning and Consolidation, version for SAP BW/4HANA
  • SAP Analytics Cloud

Reproducing the Issue

1) Set up BPC connection in SAC
2) Run Import Job in SAC for BPC model
3) Run Export Job in SAC for BPC model

Cause

Missing Configuration or Product Limitation

Resolution

  1. Check Function Restrictions:
    1. WEEK Property level is not supported yet BPC connection
    2. Importing BPC data into SAC dimension is not supported yet BPC connection
    3. SAML2 is not supported yet in BPC connection

  2. Check if Data Import - SAP BPC Connection set up correctly. 
    1. Prerequisites
    2. Import Data Connection to an SAP BPC System

  3. Check BPC data
    1. get the BPC Infoprovider info: 
      1. SE16: Embedded Model: RSBPCA_APPL_IPRV
      2. SE16: Standard Model: UJA_APPL
    2. LISTCUBE in the BPC (NetWeaver) system:
      1. Display the BPC data using the same filter/mapping based on SAC import/export job
          
  4. Check BPC data size
    1. Avoid all base members loading, add dimension filters to reduce the data size
    2. Related error log:
      1. SAC: BPC plugin error: read fact data with new json format ends in exception from BPC!
      2. BPC SLG1
        1. UJHANA_ERROR_004
        2. Call TREX_EXT_AGGREGATE failed with 9.300-: string too large
           
  5. Check BPC user [which used in the data import - SAP BPC connection type in SAC] 
    1. Check if the BPC user has the full authorization:
      1. 1994720 - Checkpoints: Authorization Issue for BPC User, Role, Task, Team and CUA configuration
      2. Check missing authorization object: SU53
      3. Check if Data access profile is assigned to the service user used in BPC connection of SAC. 
        1. Environment
        2. Model
        3. Dimensions
        4. Data Access Profile
    2. In case of HTTP 204 error during creating BPC connection in SAC, it may indicate the user has no authorization to BPC model.
       
  6. Check System Log in BPC system:
    1. Application Log: SLG1
    2. Shortdump: ST22
    3. System Log: SM21
    4. Work Process: SM66 
      1. Check heap memory and extended memory for the dialog sessions

  7. Check BPC dimension setting:
    1. Tine Dimension:
      1. Check if the BPC Time dimension has the base period properties maintaine
      2. Check the PERIOD format of MONTH time level, JAN/FEB/MAR/APR... format is suggested
    2. Account Dimension: 
      1. Check if the correct single hierarchy is selected for the Account dimension
      2. Incase the issue happens on certain hierarchy, please run BPC_MIGRATE_TO_HANA" and "UJHANA_REFRESH_VIR_CUBE" to renew the hierarchy.

  8. Check BPC Global/Environment/Model setting: 
    1. report SAP_RSADMIN_MAINTAIN 
    2. Check if the query engine in table UJO_PARAM is set via SM30 or SE16:
      1. CL_UJO_QUERY_MDXPTD2_MBRSET [usually better query performance than CL_UJO_QUERY_MDXPTD2]
      2. See SAP Note: 1858257 - How to enable SQE to support MDX member set functions
         
    3. In case of a UJHANA error, please check the HANA SQL statements:
      1. 2663090  - Temporary problems during parsing/unexpected characters in an MDX statement”
         
    4. In case of BPC Models: Optimization Process [for BPC 11.0 / BPC 11.1 version for BW/4HANA and BPC 10.1 version on BW 750. ]
      1. Check if the BPC model has optimized process when you have the data issue
      2. If there is inconsistency, please use full load mentioned in following note:
      3. 2915785 - How to Optimize BPC Standard Model when it's integrated into SAP Analytics Cloud Planning Model with Write-Back Mode
      4. If your BPC model ( BW cube) process the compress requests every day, this may cause data in the compressed requests NOT synced to write back model.
      5. In this case, you will need to apply the solution in above note. 
      6. 2913942 - Switch to Full Load mode when export data from BPC to SAC
         
  9. Check if the BPC service activated or not
    1. Check the URL used in the Data Import - SAP BPC connection in SAC. 
    2. Go to SICF and check the service is activated 
       
    1. Download Rejection Log:
      1. Hard 90K limit for log download is set to avoid network error
      2. Please solve the first 90K rejection reason, then run the job again to get new rejection log.
         
    2. Check if following notes are applied in BW/BPC system: 
      1. 2730872 - SAP Analytics Cloud and Business Planning and Consolidation 11.0 data integration with delta service fails due to hierarchy deletion of BPC dimension
      2. 2755379 - Support new json format when export data to SAC
      3. 2805032 - New JSON format ignore zero when export transaction data to SAC
      4. 2913078 - Support "Clean and Replace"
      5. 2936269 - No memory during export
      6. 2550738 - SY_530 error raised when select 'Base Level' in EPM Add-in report or load BPC data to SAC
         
    3. Check SAC Log:
      1. Tenant Home Page > System > Monitor > Trace
         
    4. Check SAML setting in the SAC BPC Import connection.
      1. When the SAML2 is disabled, SAC uses "Basic Authentication" that is username and password. Users will get the pop only for the first time or after the user changes his/her password and SAC has a secure store to save the user and password for the connection per user.
         
    5. Concurrency Lock: 
      1. Parallization Scenario:
        1. As of SAC version 2022.07, use SAC Parallel Execution parameters in the BPC model to avoid concurrency lock and enqueue server busy errors/warnings:
        2. SAP Note 3164460 - Customize system options for SAC exporting data to BPC
        3. In case of parameter SAC_EXPORT_TASKS is not set, and record involved 50000+records, the SAC data export process will split the packages [50000 records per package] and run the packages in parallel.
        4. In case of parameter SAC_EXPORT_TASKS = 1 and record involved 50000+records, the SAC data export process will split the packages and run the packages [50000 records per package] one after another. 
        5. Reference note:
          1. 1960682 -BPC NW: Error obtaining concurrency lock (foreign_lock)
             
      2. BPC MS connection scenario
        1. Check if there are mutiple instances of writing data to the same data region. 
        2. Check the lock table
          1. connect to SQL server database via MS SQL Server Management Studio.
          2. select the database of your BPC environment and find the table of name lock<BPC Model Name> and table sgQueue
          3. in normal cases, the tables should be empty when the data posting processes finish.
          4. if there are any entries in the two tables while there is no export job running, it indicates that the inconsistency situation exists.
          5. delete the content from the two tables and try the SAC export job again. 
             
    6. Check Network HAR trace and Console
      1. 2280022 - How to collect a HTTP archive (HAR) file (Chrome developer tools network trace) in SAP Analytics Cloud
         
    7. Check Gateway Setting:
      1. SAP Gateway Error Log:  /n/IWFND/ERROR_LOG
      2. SAP Gateway Backend Error Log: /n/IWBEP/ERROR_LOG
      3. SAP Gateway Application Log Viewer: /n/IWFND/APPS_LOG
      4. Service Catalog: /n/IWFND/MAINT_SERVICE
      5. Gateway Client Test: /n/IWFND/GW_CLIENT
      6. /n/IWFND/IWF_ACTIVATE
         
    8. Enable Payload Trace in BW/BPC system:
      1. Transaction /n/IWBEP/TRACES SAP Backend Tracing Tools
      2. Transaction /n/IWFND/TRACES SAP Gateway: Tracing Tools
      3. Click the "add user" button.
      4. Add the user which is used in the data import connection[SAP BPC type] in SAC. 
        1.  
        2. Change Error Log Level to “Full” and tick the option “Payload Trace”.
        3. IWFND_TRACES.PNG
        4. With the trace enabled, the user can see the http communication details in the "Payload Trace" tab once the SAC user triggers any export or import jobs in SAC.
        5. Note that: the tracing time is valid for 2 hours only.

    9. To submit a BPC/SAC issue, please provide with following information: 
      1. BPC Side
        1. BPC system ID
        2. BPC Environment/Model ID
        3. A BPC support user in the backend system to view the trace and system logs
        4. Open R/3 connection and maintain logon data
           
      2. SAC Side: 
        1. SAC Tenant Link [Enable the option to "Allow SAP support user creation" under System > Administration > System Configuration]
        2. SAC Model Link
        3. SAC Export/Import Job Name/ID
        4. The BPC user used in SAC connection[SAC-Menu-Connection] [need this BPC user ID to enable the trace log in the BW/BPC system]
        5. Share the BPC connection [SAC-Menu-Connection] to SAC support user
        6. Screen shots or Information of Error log/User ID/Date.Time of the error
           
      3. Select component:
        1. [Main] SAC Component: LOD-ANA-PL-PLI 
        2. BPC Components:
          1. BPC standard model: EPM-BPC-NW  
          2. BPC embedded model: BW-PLA-BPC
          3. BPC4HANA: EPM-BPC-BW4
        3. Gateway: OPU-GW-COR

    See Also

    • 2915785 - How to Optimize BPC Standard Model when it's integrated into SAP Analytics Cloud Planning Model with Write-Back Mode
    • 2969947 - Planning functionalities supported in SAC live connection to BPC Embedded Model
    • 1858257 - How to enable SQE to support MDX member set functions
    • 3026199 - Tips and Tricks of Analyzing BW Data Integration with SAC Issues
    • 2540886 - How to export data from models in SAP Analytics Cloud?
    • 3220729 - Checkpoints: Import and Export Job for SAC model via OData Services
    • 3220268 - Checkpoints: Import and Export Job for SAC model via S/4HANA connection
    • 3242995 - Checkpoints: Export Job for SAC model via IBP [SAP Integrated Business Planning] connection
    • 3216885 - Troubleshoot errors in SAP BPC Data Acquisition connection of SAC

    Keywords

    UJO_READ_EXCEPTION 054, Delta Load, request_tsn, timestamp, AQ, AT, request status, rspmrequest, BPC11, SAC, DATA Integration, Dimension, Hierarchy, DELTA SERVICE, "The job failed due to an unexpected internal server error" "0/0 lines imported, Writeback, OData, RSBPC, SBGRFCMON,gateway, gateway client, RSPM_MONITOR, Error obtaining concurrency lock, export, import, bpc, sac, PLANDATA_WRITEBACK; HTTP 400 EPM_SERVICE, HTTP 204, PLUGIN_EXECUTION_ERROR, SAC_EXPORT_TASKS, EPM_SERVICE, IWFND, IWFND, ERROR_CONNECT_TO_BPC, PLUGIN_EXECUTION_ERROR, BPC, sac, epxort model,HTTP 400 EPM_SERVICE "Unable to retrieve the external data due to: EPM_SERVICE "An internal server error occurred in Data Acquisition service" PLUGIN_EXECUTION_ERROR Failed to execute client request HTTP 204 BPC plugin errorAn internal server error occurred in the Data Acquisition Service PLUGIN_EXECUTION_ERROR Failed to execute client request UJHANA_ERROR_004 Call TREX_EXT_AGGREGATE failed with 9300- string too large Concurrency Lock rejection log download limitation CL_UJO_QUERY_MDXPTD2_MBRSET UJHANA DAP dat access profile UJ SEC , KBA , bpc import job failing in sac bpc import , LOD-ANA-PL-PLI , Planning Integration (BPC import/export/writeback) , EPM-BPC-NW , NetWeaver Version , BW-PLA-BPC , BPC 'embedded model' , OPU-GW-COR , Framework , Problem

    Product

    SAP Analytics Cloud 1.0