Symptom
When trying to cancel contract ABC (ABC represents the contract ID) on header level you get the following error message:
"Effective cancellation date must be between contract start and end dates" (XX represents the line item ID of a line item in the contract).
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Contracts view.
- Open contract ABC.
- Navigate to the General tab and go to the Renewal and Cancellation sub-tab.
- Enter a date in the Cancellation Effective On date.
- Maintain a Cancellation Reason.
You receive the following error message, even though the Cancellation Effective On date is between the Contract Start Date and Contract End Date maintained in the General tab Main Information sub-tab:
"Effective cancellation date must be between contract start and end dates".
Cause
Line Item XX in Contract ABC is already expired since the Contract Item End Date has been reached, but the Line Item is still in Process because the Fulfillment status is Not Started (XX represents the Line Item Number).
When you enter a Date for the Cancellation on Header Level, the system will check if that date lies in the time frame of the Contract Item Start Date and Contract Item End Date of all items.
Since Line Item XX has a Contract Item End Date which lies before the date you entered for cancellation, it does not lie in this time frame and the error occurs.
Effective cancellation date must be between contract start and end dates
Resolution
Complete the Fulfillment of Line Item XX in Contract ABC
- Go to the Sales Orders work center.
- Select the Contracts view.
- Open contract ABC.
- Navigate to the Items sub tab.
- Select Line Item XX.
- Select the Finish button and the Fulfillment option.
- Save your changes.
You can now cancel the contract in the General tab and the Renewal and Cancellation sub tab.
See Also
Keywords