SAP Knowledge Base Article - Public

3002632 - New created segmentation profile is not visible in personalization F4 help popup of Email

Symptom

The newly created segmentation profile cannot be selected for personalization in Emails or Confirmations, because it is not displayed in the F4 search help popup.

KBA 1.GIF

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Marketing Cloud Edition

Reproducing the Issue

  1. Open Emails or Confirmations in Content Studio
  2. Click on personalization search help button
  3. The new segmentation profile cannot be found in the search help popup

Cause

Missing settings in segmentation configuration.

Resolution

In segmentation configuration, please make sure following:

  1. For the relevant Segmentation Profile, application SAP_CPG_CONF_MSGS and SAP_CPG_MSGS are selected to be used in applications.
    KBA 2.GIF
  2. For the relevant Segmentation Object assigned to the Segementation Profile, the correct business object is maintained for Key field according to your needs. 
    KBA 3.GIF

See Also

KBA 2763176 - SAP Marketing - Segmentation Attribute not available in Segmentation Model
KBA 2863123 - Attributes such as Marketing Area is missing in search help of Segmentation Profile or Segmentation model

Keywords

Not show, shown, displayed, invisible segmentation profile, confirmation messages, campaign messages, email and confirmation , KBA , CEC-MKT-MEM , Content Studio: E-Mails and other messages , Problem

Product

SAP S/4HANA Cloud all versions