Symptom
You are replicating Individual Customer from External System to C4C and with two telephone numbers with the same type on the payload, however only one is visible on the C4C UI.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Web Service Message Monitoring under Administrator Work Center.
- Search for the Message ID.
- Open the payload and you will be able to see that customer is sending two Telephones for the same account.
- Go to Customers Work Center.
- Then select Individual Customer.
- Search for the ID for the Account.
- Open it.
- Go to Addresses Tab.
- Only one number is maintained.
Cause
SAP Sales Cloud as a leaner cloud solution is designed to support only a reduced set of data compared to the full-fledged on premise solutions. Therefore we only support one telephone number per type (fax, land line, mobile) per customer. When multiple telephone numbers of one type are provided, the phone number marked as default in the usage section will be stored in SAP Sales Cloud. Since there can be different phone number types (land line, mobile, fax), the service WSDL has to support more than one phone number element which are then distinguished via the content of the usage element.
Resolution
This is designed behavior. If you requires more phone numbers, you might need to create a custom extension to support further data elements filled via custom middleware logic.
See Also
For more details about the Steps to create Custom fields in C4C and extend it to integrated system (ECC), check the following blog:
Keywords
Account, Business Partner, Telephone, Number, Individual Customer. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To