SAP Knowledge Base Article - Public

2959854 - The field 'Product' , 'Contract type' under 'Billing' tab in app 'Plan customer project' cannot be changed

Symptom

Under 'Billing' tab in app 'Plan Customer Project', sometimes, the 'Contract type' and 'Product' cannot be changed.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Go to app 'Plan Customer Project'.
  2. Go to tab 'Billing'. 
  3. Try to change the field 'Contract type' or 'Product'.

Cause

The enablement of 'contract type' and 'Product' editing depends on the status of "Extracts" (The line items which are shown in the second screen of Release Billing Proposal [RBP] App) which are created in RBP App.
This is independent of the Billing Plan status. This is done for safeguarding the billing plans from being changed once the user starts editing a projects billing proposals in the RBP App.
These extracts are created based on below actions.

1. Extracts are created for the first time for all existing Server order (SO) items whenever the user clicks on "Edit" button in RBP App.
2. Extracts are automatically created for all SO Items on a daily basis (using a nightly running job) if the extracts were not created by user action (point 1) .

Resolution

This is standard behavior and normally it is not recommended to change the 'contract type' and 'product' once the stage of the project has been set to 'In Execution'.

Keywords

Release billing proposal, Billing, Product, plan customer project,  PS_FILL_EXTRACT_TABLES_REPORT, edit, 'contract type' , KBA , PS-REV , Revenues and Eamings , CA-CPD-SS , S/4HANA Public Cloud – Professional Service Projects , Problem

Product

SAP S/4HANA Cloud all versions