Symptom
When you replicate a CPQ quote back to C4C, the account contact details are not there.
Environment
SAP Cloud for Customer
SAP CPQ Integration for Quote 1.0
Reproducing the Issue
- Go to Sales Work Center, Opportunity view and create an Opportunity. Save and Open.
- On the Contact Tab, you will be able to see a contact that came from the Account related to the Opportunity.
- Go Sales Document tab, create a new quote.
- Save it.
- You will be able to see that Primary Contact is the same contact maintained on the Opportunity Contact Tab.
- However there is no Primary contact details like e-mail, Address, Phone maintained on the Sales Quote.
Cause
You are replicating your Sales Quotes using CPQ and it is relevant for CPQ version 1.0;
Resolution
This is the expected system behavior.
The creation of a CPQ Quote from C4C is triggered via the C4C Quote quick create screen if the C4C quote type is enabled for CPQ.
- When creating a CPQ Quote from SAP Cloud for Customer (C4C), the owner (employee responsible for the business transaction) must equal the current user since SAP CPQ does not support the change of the quote owner with the integration. Therefore, in SAP CPQ reassign owner is disabled. C4C shows an error if Owner for CPQ quote is not the current user. The user can change the Owner to the current user.
- The CPQ Quote currently doesn't support separate partners for the account and the contact. Only the account is transferred to CPQ but not the contact.
See Also
Keywords
Sales Quote, CPQ, Primary Contact , KBA , LOD-LE-CQP , Customer Quote Processing , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To
Product
SAP Cloud for Customer core applications all versions