SAP Knowledge Base Article - Public

2919588 - Approval Process Flow Through Employee's Reporting Line Unit Instead of Sales Unit

Symptom

You have assigned Employee A into two Org Units which are assigned as Sales Unit. When you create Sales Quote, both the Sales Quote determine same Approver instead of the managers in the respective Sales Units.

Environment

SAP Cloud for Customer

Reproducing the Issue

Step 1: Assigning Employee into the different Org Units (Function - Sales Unit)

Step 2: Creating Sales Quote

Cause

Cause for the issue is that when you assign an employee to more than one org unit, only for one Org Unit you can make Employee as Primary Org Unit assignment. This is considered for reporting line unit related approval processes

Whichever Org Unit is made as primary for employee considered for approval which is expected system behavior

Resolution

An employee needs to be assigned to one org unit as “Primary”. You can assign an employee to multiple org units once you remove the primary flag for an employee from the others org units. Only the primary org unit assignment is displayed in the employee master record and is used when determining the reporting line manager.

IMPORTANT: Only primary assignments are used also within transactions, for example a quote or opportunity, to derive the sales unit. We never use non-primary assignments.

Only "My Team..." queries and IAM authorization management check secondary assignments.

Secondly, The flag "ReportingLine" on facet "Functions" has not impact to the manager's flags ReportingLine/FunctionalIndicator

Note: Approval should only check the primary assignments. To check secondary assignments is a new requirement that could be rolled-in via https://influence.sap.com/sap/ino/#/campaign/1868.

For approval process, you can also check for the enhancement through custom determination methods via PDI

Keywords

Approval, multiple org units , KBA , LOD-LE-OM-OM , Org. Management , Problem

Product

SAP Cloud for Customer core applications 2002 ; SAP Cloud for Customer core applications 2005 ; SAP Cloud for Customer core applications 2008