Symptom
- Error "Switch to account group &1 not possible" is raised when trying to change CPD account group to another account group (Customer or Supplier) for a Business Partner.
- "Customer ******* is a one-time customer. No change of account group defined" is encountered when there is an attempt to change the account group.
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Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Open a Business Partner with Grouping CPD.
- Click on Edit.
- Change the account group.
- Click on save.
- The system raises the error.
Cause
The CPD Customer Account group is a "One-Time" account group, so it is not possible to make changes to another account group. This is hardcoded into the system.
Resolution
- Archive and then delete the CPD Customer Business Partner.
- Re-create the Customer Business Partner in the desired new account group.
See Also
2742388 - S4HC: How to delete Business Partner, Customer or Supplier Master Data in S/4HANA Cloud.
Keywords
switch, account, group, CPD, one-time, customer, supplier, CVIV_UI178, CVIV_UI 178, F2 688, F2688, LO-MD-BP, S4HC, S/4HANA, S4_PC , KBA , LO-MD-BP , Business Partners , Problem
Product
SAP S/4HANA Cloud all versions