Symptom
It is heavily recommended to upgrade to LUC 3.x for Full Support and for a much simpler deployment process.
The following error occurs using Live Universe Connect (LUC) with SAML SSO Authentication method in SAP Analytics Cloud:
- An unexpected error occurred, please contact your administrator
- We couldn't connet to your system
Environment
- SAP Analytics Cloud (Enterprise) 2020
- Live Universe Connection (LUC) to BI Platform 2.x or 3.x
Reproducing the Issue
- Configure Live Universe Connection using SAML SSO Authentication as per Product Guide
- Create the Live Connection to Universe in SAP Analytics Cloud tenant, and choose SAML Single Sign on as Authentication method
- Click Ok button
- In the small popup window, it shows the error : An unexpected error occurred, please contact your administrator
Cause
Live Universe Connect SAML metadata file, which is downloaded via https://<HOST>:<PORT>/sap/boc/ina/saml/metadata, sometimes may contain multiple X509 signing Certificates ( certificate for LUC, intermediate certificate, and root certificate). When this LUC SALM metadata file is uploaded into LUC application in SAML Identity Provider, IDP only accepts the last signing certificate, which is not the signing certificate for LUC.
You notice the validity, expiry date and subject DN of signing certificate for LUC in SAML Identity Provider are not matched with the certificate for LUC.
Resolution
Open the LUC SAML metadata file, and manually copy the X509 signing Certificate for LUC (which is usually the first certificate), and paste into the corresponding SAML Signing Certificate field of LUC application in SAML Identity Provider.
You can verify the validity, expiry date and subject DN of signing certificate for LUC in SAML Identity Provider are matched with the certificate for LUC.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
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