SAP Knowledge Base Article - Public

2855065 - Email Notification Workflow Rule not Working

Symptom

Workflow Rules for sending notifications are not working.

Environment

SAP Cloud for Customer

Reproducing the Issue

This issue will happen for all workflow rules, irrelevant of the BO:

  1. Go to the Administration work center.
  2. Go to the Workflow Rules view.
  3. Select the relevant rule.

Eventhough the rule is active, non of the recipients are receiving email notifications as per the Rule.

Cause

In a non-productive system you can specify whether e-mails and faxes should be sent to real addresses of business partners or to an address used for testing purposes. For this case choose "Send all e-mails/faxes to this address" and maintain a mail.

If no mail address is maintained here, no mails will be sent out.

Resolution

To maintain an address here or to change the settings for business partners to receive the e-mails follow below steps: 

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects view.
  3. Choose Show: All Open Projects.
  4. Choose the relevant project.
  5. Choose Open Activity List.
  6. Select Fine Tune.
  7. Search the activity E-Mail and Fax Settings.
  8. Click Open.
  9. Select E-Mail and Fax Settings.
  10. Under E-Mail and Fax Delivery in a Non-Productive System.
  11. Either select 'Send all e-mails to business partners' or select 'Send all e-mails to this address' and maintain the e-mail address.
  12. Click Save.

Keywords

E-mail missing; Notification failed; No Output; Email , KBA , LOD-CRM-WKF , Workflow , LOD-LE-CQP , Customer Quote Processing , Problem

Product

SAP Cloud for Customer core applications all versions