SAP Knowledge Base Article - Public

2843532 - Automatic Account Creation is not working when assigning a Time Type to a Time Profile

Symptom

  • You have created a new Time Type and a New Time Account Type with automatic account creation.
  • Then you have assigned this Time Type to an existing Time Profile, however you have noticed that the Account was not created automatically.

Environment

  • SAP SuccessFactors Employee Central - Time Off

Reproducing the Issue

Pre-conditions:

  • Time Type has a Time Account Type.
  • Your time Account Type has the setting Account Creation Automation as Automatic Account Creation.
  • The Time Profile is already assigned to an employee.

Issue Replication Steps:

  1. Create a new Time Account Type and make sure this is set as Automatic Account Creation;
  2. Create a new Time Type and assign the Time Account Type (from step one);
  3. Assign the Time Type (from step 2) into an existing Time Profile;
  4. Notice that the account is not automatically created for employees already assigned to this Time Profile

Cause

  • This is Expected behavior
  • This setting was not meant to create the current account even in scenarios where time profile is updated.
  • If the employee already has the time profile assigned and we add a new time type (that has a time account type) to that time profile, regardless of being set as automatic or not, the new time account won't be created.
  • The purpose for the automatic account creation set is the subsequent account creation and if needed past account creation.
  • For more information about this feature, please refer to Creating a Time Account Type

Resolution

  • To create the account for employees already assigned to the time profile changed you need to run the Account Creation Calendar regardless of having the Account Creation Automation.

Keywords

account not created automatic account creation automation of time accounts , KBA , LOD-SF-EC-TIM , Time Off , Problem

Product

SAP SuccessFactors Employee Central all versions