SAP Knowledge Base Article - Public

2838745 - HTTP Status 404 – Not Found error when configuring SAML SSO for BOE Live Data Connect in SAP Analytics Cloud (SAC)

Symptom

It is heavily recommended to upgrade to LUC 3.x for Full Support and for a much simpler deployment process.

  • When you go to https://<HOST>:<PORT>/sap/boc/ina/saml/metadata to download the metadata file (spring_saml_metadata.xml) of Service Provider (LUC), you get the following error:
  • HTTP Status 404 – Not Found
    Type Status Report
    Message /sap/boc/ina/saml/metadata
    Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.
    Apache Tomcat/8.5.13
  • When you try to save the Live Data Connection with SAML Authentication in SAP Analytics Cloud, you get the following error:

HTTP Status 404 – Not Found
Type Status Report
Message /sap/boc/ina/cors/auth.html
Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.
Apache Tomcat/8.5.13.

Environment

  • SAP Analytics Cloud 2019
  • BOE Live Data Connection to Universe (LUC) 2.x or 3.x
  • Business Intelligence Platform 4.2 SP5+

Reproducing the Issue

  1. Follow the Product Guide to configure Live Data Connection to Universe
  2. Got HTTP Status 404 – Not Found error when downloading the metadata file of BOE Live Data Connect

Cause

For HTTP Status 404 – Not Found (/sap/boc/ina/saml/metadata) error, it is usually caused by an error or omission related to securityContext.xml file or keystore or signing certificate.

Resolution

In this case:

  1. Open the xml file in a text editor, and insert the below CookieProcessor segment to set the SameSite attribute to None,as per this Help Guide

    <Context docBase="" path="/sap/boc/ina" reloadable="false" useHttpOnly="true"> <CookieProcessor className="org.apache.tomcat.util.http.LegacyCookieProcessor" sameSiteCookies="none" /> </Context>

  2. Ensure to remove or comment out the following line in securityContext.xml file, as per this Help Guide.

    <bean class="org.springframework.security.saml.key.EmptyKeyManager" id="keyManager"/

  3. Then, add the following block of code as per this Help Guide.

    <bean class="org.springframework.security.saml.key.JKSKeyManager" id="keyManager">

    <constructor-arg value="/WEB-INF/samlKeystore.jks" />

  4. Restart Tomcat

For detailed step-by-step instructions on configuring Live Universe Connection with SAML SSO Authentication in SAC, you can refer to this blog. The workflow is applicable to any Identity Provider compatible with SAML 2.0 protocol.

https://blogs.sap.com/2019/01/27/sap-analytics-cloud-configure-saml-sso-live-data-connection-to-sap-universe-using-sap-cloud-platform-identity-authentication-sci-identity-provider/

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO , KBA , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , LOD-ANA-LDC-UNV , SAC Live Data Connection Universe , Problem

Product

SAP Analytics Cloud 1.0