Symptom
- When searching within the Live Activity work center by a Business Partner Name, all the activities (Ticket, Accounts, etc.) appear as result of the search.
- When searching using the Business Partner ID, only one result appears (the own business partner).
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service work center.
- Select the Live Activity Center view.
- Search for the Business Partner 123 (123 represents the Business Partner ID).
- Only one result appears.
- Now search for the Business Partner name, multiple results will appear.
Cause
This is correct and it is based on how the Live Activity search works.
Resolution
- C4C does a text search on the key word. When an ID is added, the search uses the ID as a text and the returns only the Business Partner ID, because that ID is not appearing as a text in any other record (Tickets, etc.)
- When you search for a name, the search uses the name as a text and all the results where the name is present start coming up.
See Also
Keywords
Live Activity; CTI; Business Partner; Search; ID; , KBA , LOD-CRM-LA , Live Activity , How To
Product
SAP Cloud for Customer core applications all versions