Symptom
- Unable to save RBP permissions for "Data access report story".
- RBP permissions are not getting saved when specific templates are selected under "Data access report story".
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Cloud
- SAP SuccessFactors Performance and Goal Management
Reproducing the Issue
-
Go to Admin Center > Manage Permission Roles
-
Edit the target permission role and Click on Permissions
-
Go to Performance Section
-
Select Data access - Report Story
-
Select Others and select some template
-
Click on 'I'm done'
-
Click on 'Save Changes'
-
You will see the error 'Error updating permission role [roleId=0]' and the permissions are being not saved.
Cause
This is an environemnt issue that is usually caused by missing/failed database upgrade script.
Resolution
- If you are a customer you do not have access to Provisioning, you need to contact your Implementation Partner or create an case with Support (LOD-SF-PM-ADM).
FOR PARTNERS AND SAP SUPPORT ONLY:
1. Logon to Provisioning
Logon to the Provisioning, choose the company.
Navigate to:
-
Managing Job Scheduler
-
Manage Scheduled Jobs
2. Create New Job
In Manage Scheduled Jobs,
- Click the link: Create New Job
In Create New Job page, fill in the parameters:
- Job Name: (any text which can identify this job)
- Job Owner: (usually the system admin / super user)
- Job Type: Company Schema Upgrade Job
- Rerun Options: com.successfactors.pm.service.common.AddPMUTemplatesToRBP
- Occurrence: Once
- Click button: Create Job
3. Run the Job
Come to Manage Scheduled Jobs page,
- Find the job we just created
- In the column Actions
- Click the Select button
- Click Run it Now
4. Check the Result
-
Come to Monitor Jobs page,
- Choose Job Type: Company Schema Upgrade Job
- Click button Refresh
In the job, we may find its Status is In Progress.
- After some time, its Status could be Completed
5. Refresh RBP
Go to Provisioning >Company Settings > Run the "Refresh RBP Permission Configuration. Issue will be resolved.
-
The Company Schema Upgrade Job searches for the script file in company_upgrade.csv. The job fails if the script name is incorrect or it doesn't exist.
-
If you do not have access to provisioning, please contact your implementation partner or raise a support ticket.
-
If the message "Throttling Threshold is Reached" appears when executing the job, please follow the steps of the article: 2735903 - "Throttling Threshold is Reached" error on running Company Schema Upgrade Job
See Also
2584660 - Permissions are not getting saved - Employee Central
Keywords
Error updating permission role [roleId=0], RBP error, Permission error, Data Access report story, SAC, Reporting , KBA , LOD-SF-PM-ADM , Admin Center, RBP, Permissions and Settings , LOD-SF-PM , Performance Management , LOD-SF-ANA-SAC-RBP , Role Based Permissions & Authorizations , LOD-SF-MTR-ADM , Admin Center, RBP, Permissions and Settings , Problem