Symptom
When sending an adhoc notification to 500+ users, receive a Gateway Timeout Error.
Environment
SAP SuccessFactors Learning Management System (LMS) - 1908 & earlier
Reproducing the Issue
- Go to User Search.
- Search for an Organization or some other filter that has more than 500 users but no more than 2.5k users.
- On the Record per page, change to All to get more than 500 users.
- Select All and then click on Send Notifications.
- After 2 minutes a Gateway Timeout will be seen.
Cause
The adhoc notification was never intended to send out more than the initial amount as guarded when using the same tool from an entity/item and is guardrailed to prevent performance degredation; however enhancement was made to behave as previously seen for many customers.
Resolution
This was enhanced to include support for about 2-2.5k users via LRN-61628 & PTCH-30748 for production environment 1905p15 (23-Aug-19) and for preview environment LRN-63636 & PTCH-30852 for 1908p2 (23-Aug-19).
{Note at time of release 1908 will be in preview environments}
Keywords
SAP SF success factors LMS Learning LRN-61628 PTCH-30748 LRN-63636 PTCH-30852 ad-hoc adhoc ad hoc notifcation send user tool users gateway timeout error supervisor supervisors email notifications , KBA , LOD-SF-LMS-BCJ , Assign (bulk), Add/ Delete Sub/ Cur, Revise, Import , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS-NOT , Notifications , Problem