Symptom
- Learning users are reporting when they are searching for an item in the library search within the user interface, a specific Item is not visible in the search results
- The Item is set to display in library and the library is assigned to users
- In the Library Preview, it is being shown for users, but no users are able to find the itemID when searching the catalogue
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Log in as user
- Perform a search for the item using ItemID, Item Title, Item Description
- No results are showing
Cause
The Item has not been Productionized by the administrator after various revisions were made recently to the affected Item or newer producitonized revision exists.
Resolution
Ensure when performing item search radial selecitons selected to show all locales, orders, & status of items to see all revisions.
Productionizing the Item will propogate all the recent changes and revisions and will allow the Item to be displayed and searchable in the user Catalog Search:
See Also
KBA 2687419 - Cannot search for an item within a catalog
KBA 2252061 - No Option to Revise Item In "Actions" Menu
Keywords
SF, success factors, LMS, no results, user, productionize, revision, changes, sap, learning, catalog, search, cannot, find, display, item, SKU, catalog, library, not show, library, master, inventory , KBA , LOD-SF-LMS-CAT , Catalog , Problem