SAP Knowledge Base Article - Public

2818171 - Unable to make fields visible via Fiori Adaptation

Symptom

Fields are greyed out while trying to make it visible via Fiori Adaptation

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Log in to Fiori client.
  2. Enter Adaptations mode.
  3. Open any TI , for example Tickets.
  4. Click the Edit icon on the header.
  5. You will see few fields for example Type, Subject are greyed out and cannot make it visible.

Cause

Personalize option for the fields are not enabled

Resolution

  1. Go to Tickets.
  2. Open a ticket.
  3. Go to Adaptation mode.
  4. Click the pencil icon just in the header section.
  5. Now in the right panel you will see 2 options , header and General information.
  6. Click the arrow next to "General Information".
  7. You will see the fields Type, Subject etc.
  8. You will see that the field subject that you want to add is greyed out. Click the arrow next to subject and enable the option "Personalize".
  9. Now you will see another option called Hide available , uncheck that and you will the field subject in the header.
      

Keywords

Fiori Adaptation, field greyed out in adaptation, unhide fields , KBA , AP-RC-UIF-FLX-FRW , UI Adaptation Framework , Problem

Product

SAP Cloud for Customer core applications all versions