SAP Knowledge Base Article - Public

2816159 - Tickets Created via SOAP (ServiceRequestIn) Shows Scrambled Interactions in Fiori

Symptom

When trying to create a ticket via SOAP using the web service ServiceRequestIn in Fiori, the ticket description appears scrambled within the Interactions.

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Create a Ticket via SOAP using the standard Web Service (ServiceRequestIn).
  2. Using Fiori go to the Service work center.
  3. Open the Ticket ABC (ABC represents the Subject of the Ticket).
  4. Go to the Interactions facet, the Description will be scrambled.

Cause

The SOAP service has limited formatted text for ticket maintenance. If the SOAP is used to send formatted text content with html tags into plain text content attribute, C4C will not correct display the data, since this format text is not supported.

Resolution

To achieve this scenario, please use OData API 2.0. This has been developed to satisfies most of the integration use cases and does not have the same text limitation as the SOAP.

To configure it, please check the ODATA API Guideline.

Keywords

Odata; SOAP; Ticket; Interactions; , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions