Symptom
"phoneCountryCode" Field is not showing in Candidate Profile
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
Step 1: Configure "phoneCountryCode" field in Candidate Profile
Sample Code Captured from the Implementation Guide:
<field-definition id="phoneCountryCode" type="picklist" required="true" custom="false" anonymize="true">
<field-label mime-type="text-plain"><![CDATA[Country/Region: ]]></field-label>
<field-description><![CDATA[Country/Region]]></field-description>
<picklist-id>country</picklist-id>
</field-definition>
Step 2: Grant Write/Read Permission to Candidates in Candidate Profile
Step 3: Access Candidate Profile and "phoneCountryCode" field is not available.
Cause
"phoneCountryCode" will only be visible or editable if Recruiting - SMS Messaging Functionality is enabled.
Resolution
Solution 1: Enable SMS Messaging Functionality (need for SMS Interview Notification)
KBA: 2336022 - How to Enable SMS Interview Notifications - Recruiting Management
Solution 2: Create a Custom Picklist Field such as "cust_phoneCountryCode" with almost same configuration of the Standard phoneCountryCode field.
KBA: 2786294 - Add Picklist Field on Candidate Profile via Manage Templates - Recruiting Management
Also Note : (phoneCountryCode and optInCellNumber) will not follow the labels defined in the template (for internal candidate profiles under Careers -> My Candidate Profile)
See Also
KBA: 2258199 - SCR Form: XML Software Change Request for Requisitions and Recruiting Management - Recruiting Management
Keywords
phoneCountryCode, country, code, SMS , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem