SAP Knowledge Base Article - Public

2791297 - Error: "Only One Top Category is Permitted; More Than One Top Category Exists" While Creating Product Categories Using Data Workbench

Symptom

You are trying to import product categories into your system, using the Data Workbench tool, but you are receiving the below error message:

"Only one top category is permitted; more than one top category exists"

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Data Workbench work center.
  2. Click on Import.
  3. Select the Individual Business Object radio button.
  4. Search for Product Categories in the object list.
  5. Click on Next.
  6. Upload your template.
  7. Click on Next until you reach the Import button.
  8. Go to the Monitor view and see the import has failed, with the error message mentioned in the Symptom section.

Cause

In the CSV template, you may be creating subcategories directly under ROOT, if you are creating these subcategories directly under ROOT the 'Parent_Product_Category_ID' value should be 'ROOT', instead of empty.

Resolution

To solve the error, add the value ROOT to the 'Parent_Product_Category_ID' of the subcategories you wish to create directly under ROOT and import the file again.

Keywords

data workbench, import, product categories, product category hierarchy, only one top category is permitted, subcategory , KBA , LOD-CRM-INT-DWB , Data Workbench , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions