SAP Knowledge Base Article - Public

2789795 - Instance Pairing lssue - The Application Encountered an Unknown Error

Symptom

  • You are getting "The application encountered an unknown error" message when you click on "Generate Token" on the Instance Pair Wizard window.
  • Token is not displaying on the Target instance after generating on the Source instance

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

For Instance Refresh

  1. Go to Admin Center
  2. Look for Instance Refresh
  3. Once in the Instance Management landing page select Instance Refresh
  4. Click on Next
  5. Click on Create New Request button
  6. Click on Add New Pair
  7. Fill in the Target Details
  8. next screen clicks on Add New Pair
  9. Click on Generate Token button
  10. You receive the following error message: The application encountered an unknown error

Refresh.png

For Instance Synchronization

  1. Go to Admin Center
  2. Look for Instance Synchronization Wizard
  3. Click on Launch the Instance Synchronization Wizard
  4. Next screen clicks on Add New Pair
  5. Instance Pair Wizard pop-up
  6. Insert information required and click on Generate Token
  7. You receive the following error: The application encountered an unknown error

Capture2 (1).JPG

Cause

  • User do not have the required Admin access to MDF OData API permission (under RBP Permission > Manage Metadata Framework );
  • Metadata Cache issue.
  • Permissions are not assigned on both Source and Target instances

Resolution

Ensure to perform the following steps:

  1. Go to Admin Center > search for OData API Metadata Refresh and Export
  2. Perform a Refresh Metadata Cache (please follow the steps from KBA 2171588 - OData API Metadata Refresh and Export - SuccessFactors )
  3. After you perform the Refresh Metadata Cache please try to generate the token once again.

Also ensure that both admin users on the Source and Target instance have the required permissions:

  • Manage Refresh
  • View Refresh Request
  • Admin access to MDF OData API

If the issue persists please raise a support case under component LOD-SF-PLT-IRT

See Also

2605062 - Unable to find the target instance in the 'Configuration Sync Wizard' dropdown in the source instance

2171588 - OData API Metadata Refresh and Export - SuccessFactors

Keywords

The application encountered an unknown error - Instance Synchronization, Instance pair wizard, generate token error, Instance Refresh, Instance Sync tool , KBA , LOD-SF-PLT-IST , Instance Sync Tool , LOD-SF-PLT-CGC , Configuration Center , LOD-SF-PLT-IRT , Instance Refresh Tool , Problem

Product

SAP SuccessFactors HCM all versions