SAP Knowledge Base Article - Public

2748160 - "Triggers" Not Enabled on the Creation of Campaign in the Build Facet

Symptom

You want to maintain an action on "Triggers" for a campaign, but no option is enabled in the Build facet.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales Campaign work center.
  2. Go to the Campaigns view.
  3. Open a campaign with status "In Preparation".
  4. Go to the Build facet.
  5. Add a target group.
  6. Add the action "Send E-mail".
  7. "Triggers" are not enabled.

Cause

This campaign is set to work with "Recurrence". If a campaign is executed with recurrence, the system does not allow to select "Triggers". The system only allows to select "Triggers" if the execution of the campaign is immediately or scheduled.

Resolution

This is the system expected behavior.

You need to remove the recurrence with the below steps:

  1. Go to the Sales Campaign work center.
  2. Go to the Campaigns view.
  3. Open a campaign with status "In Preparation".
  4. Go to the Details facet.
  5. In the section "Scheduled", remove the flag of the field "Recurrence".

Keywords

Triggers, Campaign, Build , KBA , LOD-CRM-MKT-CAM , Campaigns , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions