Symptom
You noticed that territories were deleted from opportunities by the user SAP_SYSTEM.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Go to the Sales work center.
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Click on Opportunities.
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Open Opportunity XYZ(XYZ represents the id of the opportunity).
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Go to the changes facet.
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Check that the territory has been deleted by SAP_SYSTEM.
Cause
This is because of party redetermination scoped in the system. Territories will be deleted if the following logic is met:
- Territory on the Opportunity was assigned by Party Determination logic.
- The Account of the Opportunity is now assigned to multiple territories.
Resolution
This is the current system behavior, the party re-determination question can be found in the following path:
- Go to the Business Configuration work center.
- Click on Edit Project Scope.
- Go to the step Questions.
- Dropdown New Business.
- Select Opportunities.
- Search for the question: "Do you want to automatically re-determine opportunity parties based on changes to the account team of the associated account?
- Result: If you enable this functionality, there is risk of territories being deleted from opportunities if the conditions described in the previous section are met.
Keywords
Master Data; Opportunities; Sales; Territories , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-ACC , Account , How To
Product
SAP Cloud for Customer add-ins all versions