SAP Knowledge Base Article - Public

2728344 - Territories Deleted by SAP User in Opportunities

Symptom

You noticed that territories were deleted from opportunities by the user SAP_SYSTEM.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Click on Opportunities.
  3. Open Opportunity XYZ(XYZ represents the id of the opportunity).
  4. Go to the changes facet.
  5. Check that the territory has been deleted by SAP_SYSTEM.

Cause

This is because of party redetermination scoped in the system. Territories will be deleted if the following logic is met:

  • Territory on the Opportunity was assigned by Party Determination logic.
  • The Account of the Opportunity is now assigned to multiple territories.

Resolution

This is the current system behavior, the party re-determination question can be found in the following path:

  1. Go to the Business Configuration work center.
  2. Click on Edit Project Scope.
  3. Go to the step Questions.
  4. Dropdown New Business.
  5. Select Opportunities.
  6. Search for the question:  "Do you want to automatically re-determine opportunity parties based on changes to the account team of the associated account?
  7. Result: If you enable this functionality, there is risk of territories being deleted from opportunities if the  conditions described in the previous section are met.

Opportunity party redermination.png

Keywords

Master Data; Opportunities; Sales; Territories , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions