Symptom
On Employee Profile, fields linked to picklists are displaying numeric values instead of labels.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
- SAP SuccessFactors Employee Central
- SAP SuccessFactors Employee Profile
Reproducing the Issue
For the purpose of this KBA, we will use the example of the 'Title' field in Personal Information, but this issue can happen for any field with a Picklist assigned.
- Navigate to Admin Centre > Search for a User
- Scroll to 'Personal Information'
- Note that the field 'Title' is displaying numeric values
- Navigate to Admin Centre > Manage Business Configuration > Select HRIS Element 'personalinfo'
- Scroll to the 'Title' field > Click 'Details' > The field is using Picklist 'ACADEMIC_TITLE'
- Navigate to Admin Centre > Picklists Management (or 'Picklist Center') > Export the Picklist File > Search for 'ACADEMIC_TITLE' Picklist > No translations are showing as Numeric Values
Cause
1) Picklist assigned to the field has been changed (Configuration Issue)
This issue occurs when the Picklist assigned to a field has been changed. With the old Picklist assigned to the field, a value was saved for the field using this picklist. After the Picklist associated to the field was changed, the values that were maintained do not delete automatically. The system cannot insert the old value as this picklist is no longer associated to this field, so it sends the 'OptionID' of the old Picklist.
In our example the field 'Title' previously used the Picklist 'customTitle'. The picklist value maintained on the field was 'pH.D'
After the Picklist associated to this field was changed from 'customTitle' to 'ACADEMIC_TITLE', the system sends the OptionID of the Picklist 'PHD', which is what we see on the field, a value '24965'
2) After MDF Picklist migration, one or more picklist fields display optionId
Depending on the decisions taken prior to the Picklist Migration, you might need to review and eventually adjust their references in EC after migration.
Resolution
1) If the issue is due to the picklist assigned to the field has changed, then:
To get rid of the numeric value you can maintain a value with the current Picklist on the field. Alternatively you can re-import the data for the affected users and leave the affected field blank.
To avoid issues like this arising during implementation, please ensure you are maintaining the correct Picklist value for a field by reviewing the Employee Central Data Objects Table here
You can also run an Audit on Manage Business Configuration to review the changes made to the field and picklist.
2) If your instance has just undergone an MDF Picklist Migration
Please follow the same steps above to try and identify if there is a mismatch between the Picklist identifier configured in EC and the LegacyPicklistID in Picklist Center.
Please note that the picklist identifier used in EC (including the picklist identifier you see in BCUI) is named LegacyPicklistID in Picklist Center. Therefore, when reviewing references, you should compare the picklist identifier you see in EC with the LegacyPicklistID you see in Picklist Center.
Also, please ensure that the respective labels/translations are maintained correctly. If it all seems correct and you still face the issue, please report a customer case for further assistance.
For additional information, please refer to KBA 2328179 - Post Picklist Migration Guide - SuccessFactors HXM Suite
See Also
2651585 - Manage Business Configuration: How to Generate Business Configuration Audit logs via Manage Scheduled Jobs
2604836 - Manage Business Configuration: How to Read Business Configuration Audit Logs
Keywords
OptionID, Numeric Value, Numbers, Picklist, Picklists Management, Field Number, BCUI, Personal Information, Job Information, People Profile, picklistId, external_code, Translation, migration , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem