Symptom
- "No data" displays while access the Alert under Take Action from the Home Page tile
- This alert is no longer valid because the source data was deleted. Please click Done to remove the alert
Environment
Employee Central
Reproducing the Issue
- When an Alert is triggered and then the corresponding record (for example Job Information record that triggered the alert) has been deleted from the system, and then when trying to access the corresponding Alert from the "Take Action" tile on the Home Page, the Take Action pop-up loads but displays the text "No data"
- When viewing the Take Action tile, Alerts are displayed with "This alert is no longer valid because the source data was deleted. Please click Done to remove the alert"
Cause
The record that triggered the corresponding Alert has been deleted (for example the JOb Info record that triggered this Alert has been deleted).
Resolution
Pre-1808: The text "No data" would display in the Take Action pop-up.
Post-1808: The message "This alert is no longer valid because the source data was deleted. Please click Done to remove the alert" is displayed instead.
Keywords
alert triggered job data deletion, alert triggered comp data deletion, alert triggered emp info data deletion, [[MY_TOKEN]], [[SUBJECT_USER]], [[EVENT_REASON]], [[EFFECTIVE_DATE]], No data, ec alert , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , Product Enhancement