SAP Knowledge Base Article - Public

2673907 - Duplicate Jobs can be seen on the RMK site - Recruiting Marketing

Symptom

  • Duplicate jobs can be seen on the RMK site, even though they all refer to the same job in RCM
  • Duplicate jobs can be seen on the Google Map, even though they all refer to the same job in RCM

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

  • SAP SuccessFactors Recruiting Marketing
  • Career Site Builder 

Reproducing the Issue

  1. Search the RMK site for jobs
  2. The search results show several entries for the same job or the Google Map will show duplicate jobs for one location

Cause

The Job was posted in RCM in More than one Language (Posting Language)
In RMK, this creates one entry for each associated locale (as expected).
Without the proper configuration, all entries will be shown at the same time on the search results page.

For the Google Map, when a job has been posted in more than one locale, it is the expected behavior that the map will show the same jobs posted in several locales. 
To avoid this and restrict the search in Google Maps by locale, refer to the configuration Search Filtered by Locale in the Google Job map component as per KBA 2870976 - The same job requisition is appearing in Google Maps twice or not at all - Recruiting Marketing

Resolution

To ensure the job search returns only one job according to the language selected by the candidate, the option "Limit Search by Locale" must be enabled as follows:

  1. Open CSB configuration
  2. Open Appearance/Global
  3. Click on Search tab
  4. Switch slider "Limit Search by Locale" to Yes

limit_search_by_locale.png

Important Notes:

  • The job's posting language in RCM is what is taken into account. The language the job description is written in has no bearing on the process. (though these should always match)
  • RMK will not translate the content of the job description automatically, only the page itself, so it is possible to end up with mixed languages on a job page if the configuration is not done properly
  • The RMK locales enabled must always match the posting languages used in RCM
  • This setting only applies to search pages. Job lists on category pages are not affected by this feature. The rules governing these pages take precedence. So if the category rules do not specifically contain a limitation on locales then all jobs fulfilling the other criteria of the rule will apply and the same requisitions will show in all the locales provided they are present on the site. The workaround is to include locale as a criterion in the rules. Note this being enhanced with release 1H2022 so a locale filter will be added to the rule if the option is on.
  • If using Limit Search by Locale, only jobs posted within a specific language will appear when accessing the RMK website in the same language. Example: If you have 15 jobs posted in English, but only 3 of those are posted in also Spanish (thus English AND Spanish), candidates accessing your RMK website in Spanish will see only 3 jobs posted.
  • Limit Search by Locale does not apply to the Google Map. Hence, enabling this setting will only apply to the job search, not the map. (There is however an option under the Google Job Map component to enable Search Filtered by Locale. If enabled, job searches performed on the Google Job map are filtered by locale.)

See Also

2670155 - Search Settings for Career Site Builder - Recruiting Marketing

Keywords

CSB, language, twice, Limit Search by Locale, rmk, duplicate, jobs, search , KBA , LOD-SF-RMK-CSB , Career Site Builder , LOD-SF-RMK-INT , Int with RCM, Data Mapping, AwLi, Multilocation posting , Problem

Product

SAP SuccessFactors Recruiting all versions