Symptom
You are tying to access the Manage Time Off Calendar UI and you are getting the following error message:
"The oData request failed. Please verify you have all necessary permissions."
Environment
- Employee Central.
- You have Time Off Implemented.
- You are not using the MDF object Pay Group.
Reproducing the Issue
- Log in the instance with any user regardless of the permission level.
- Go to Admin Center.
- Try to access Manage Time Off Calendars.
- Get the error message
Cause
Object Pay Group is inactive
Resolution
- Go to Configure Object Definitions.
- Select Object Definitions.
- Click in "Advanced" and select "Including Inactives:" to Yes.
- Search for Pay Group.
- Click Take Action > Make correction.
- Set the object as Active and save it.
- No go to OData API Metadata Refresh And Export.
- Click in Refresh Metadata Cache click in "refresh".
After performing those steps the issue will be fixed.
Important Note: After carrying out the above steps please check if you are now encountering an error while the Pay Component Non Recurring Portlet is loading on users profiles. If so, cache needs to be cleared. Please see KBA: 2688190 - Application Error Loading Pay Component Non Recurring Portlet
See Also
Keywords
manage time off calendars odata , KBA , LOD-SF-EC-TIM-CAL , Calendar Jobs , How To