SAP Knowledge Base Article - Public

2650937 - Lead Associate Account And Contact Creates Prospect If No Account Is Selected

Symptom

You are using the action Associate Account and Contact in a Lead. You are not selecting an existing account from the duplicate check pane to the right and saving it; the system icreates a Prospect instead of an Account in this case.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Open the Leads view.
  3. Open the Lead ABC (where ABC stands as ID of a Lead eligible for associating an Account and Contact).
  4. Click in the Actions button.
  5. Select Associate Account and Contact.
  6. Fill in the needed fields in the Associate Account and Contact pop-up.
  7. The system will suggest accounts in the right pane (duplicate check) based on the fields filled in the step 6.
  8. Click in the Save and Open button (not selecting any of the accounts suggested in the right pane).
  9. In the Lead ABC header, click in the account hyperlink.

The created record will be an Prospect (Prospect checkbox flagged) and you expected an Account instead (Prospect checkbox unflagged).

Cause

You are using the action Associate Account and Contact in a Lead. The system expects that existing accounts will be selected by doing this. With the information provided and still no account selected, the system infers that you are still dealing with a prospect in this case.

Resolution

This is the system current standard behavior. If you intend to create a new account since the first moment, you should use the option Convert to Account and Contact in the Lead Actions menu instead of Associate Account and Contact .

If you need to create accounts using the Associate Account and Contact inside a Lead, you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center. You can contact Cloud Service Center as follows:
a) If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.
b) If you are a customer: please use the little blue box 'Contact Us' shown on the very right hand side of https://www.sap.com/services/application-development.html, choose 'Contact Us', choose 'Services', choose 'SAP Custom Development' and complete the page.

Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.

An alternative option may be to check the SAP Customer Influence Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer

Keywords

Lead ; Account ; Prospect ; Associate Account and Contact ; , KBA , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions