Symptom
How to maintain the Reason for Rejection in Project Based Sales Order items
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Order work center.
- Go to the Sales Order view.
- Search and Edit the Sales Order ABC and click the View All button (ABC represents the Sales Order ID).
- Go to the Items tab and select line which is of type project based items like Service - fixed price (project), Service - time and material (project), etc.
You can see the Reason for Rejection is no more editable.
Cause
The Sales Order cannot be canceled if it is invoiced or it is delivery finished. The Reason for rejection field of the sales order item could be set/editable only if the invoicing status is Not Started and delivery is not Finished.
Resolution
To revoke the Invoice status, you have to make Invoice Status as Not Started for that you have to cancel the follow-up documents like project invoice request and customer invoice.
To revoke the Delivery status, you need to edit the referenced project task, change the status back to Release by selecting Revoke Close/Completion.
Once these are done, the Reason for Rejection field will be enabled, and you can maintain a value to cancel the line.
If you want to cancel the entire sales order then you have to revert all the items Invoice Status as Not Started.
Please note that are not able to revoke the completion status in project tasks if there are Project Invoice Requests with the status In Preparation. In this case you will have to delete these Project Invoice Requests first or Invoice them.
See Also
KBA 1854924 - How to maintain the Reason for Rejection in Project Based Sales Order Item
For cancellation of non-project based items in Sales Order, please refer to KBA 1755905 - You are not able to Cancel a Sales Order
Keywords
Project sales order, Reason for Rejection, Close sales order, cancel sales order line item, cancel sales order, Reason For Rejection Field Grayed Out , KBA , AP-SLO-PRO , Sales order project processing , How To