Symptom
Two different assignments in the same time period can be created for the same Service Technician and no warning message is being displayed.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the Resource Scheduler work center.
- Go to the Resource Scheduler view.
- Select the Day view.
- Planner ABC (ABC represents the user ID) creates an assignment for Service Technician XXX (XXX represents the Service Technician ID) from 14-16 PM.
- Planner DEF creates an assignment for Service Technician XXX from 14-17 PM.
Cause
In Resource scheduler - Day view the planner has the complete view of technician's availability. The complete flexibility is given to the planner to create assignment exactly at the time slot where the demand is dropped in (respecting the working hours). The overlapping of assignments is allowed.
In week/month view the planner does not get the complete granularity on technician's availability. The system will automatically place the assignment to the first available working hours. In this case the assignment will not get created with overlapping start time.
Resolution
This is the expected system behaviour.
The system is currently not showing a warning message if there are overlapping assignments. The functionality is planned to be made available in a higher release. At this point in time, we are not able to provide more accurate information on date and/or timelines for this future release.
Keywords
Resource Scheduler, Assignments, Service Technician, Overlapping Times , KBA , assignments , resource scheduler , service technician , LOD-CRM-RES , Resource Scheduling , Product Enhancement