Symptom
Users do not have access to the Canvas Report even though the permissions are set for to be controlled by RBP on the Manage Workforce Analytics.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Access the reporting tab.
- On Report Center select new and the section below where the Report - Canvas in red is not available.
Cause
This is happening because the option to use the RBP permissions over the Analytics role is enabled, but is not refreshed.
Resolution
- Go to "Manage Workforce Analytics" under Admin Center > Reporting and Analytics
- Disable "Functional and Option Permissions" and select save
- Enable the option again and save
- Log out of the instance
- Clear the cache and Log in again
The behavior should be as expected now.
See Also
Other possible causes and fixes: 2796673 - Report Canvas is unavailable in Report Center
Keywords
Canvas, report, not, visible, appearing, missing, ORD, not, working, see, unavailable, Center, Legacy, Report, Distributor, Tool , KBA , LOD-SF-ANA-RCT , Report Centre , LOD-SF-ANA-ORD , Online Report Designer , Problem