SAP Knowledge Base Article - Public

2600865 - Opportunity Status Changed to Stopped does Not Update the Probability Field

Symptom

You are changing an opportunity status to Stopped and the probability field is not being updated as you expect (to 0%).

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Logon the system.
  2. Go to the Sales work center.
  3. Select the Opportunities view.
  4. Open opportunity ABC (where ABC stands as the ID of an opportunity currently with In Process status).
  5. Click the Actions button.
  6. Select 'Set as Stopped'.

You notice that the opportunity probability was not updated to zero percent as you expected.

Cause

This is the current system behavior. Please note that statuses Won and Lost update the probability field automatically.

Resolution

As workaround, you can set a workflow rule to achieve this behavior. Follow the steps below:

  1. Logon the system.
  2. Select the Administration work center.
  3. Open the Workflow Rules view.
  4. Click in the New button.
  5. On Step 1 of the workflow rule creation, fill in the name field, select Opportunity in the dropdown menu Business Object and set its timing as On Every Save.
  6. Click Next.
  7. Click the Add Group hyperlink.
  8. In the pop-up, select Status in the field dropdown menu.
  9. Select Equal to in the Compare Operator dropdown menu.
  10. In the blank dropdown menu to the right, select Stopped.
  11. Click in the OK button.
  12. Click in the Next button.
  13. In the Rule Type dropdown menu, select Field Update.
  14. Click in Add hyperlink.
  15. In the Edit Field pop-up, select Probability in the Field dropdown menu.
  16. Fill in the Value field as desired.
  17. Click in the OK button.
  18. Click in the Next button.
  19. Click in the Activate button.
  20. Click in the Finish button.

See Also

Keywords

Opportunity, won, lost, Sales Phase Stopped Status Probability , KBA , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions