SAP Knowledge Base Article - Public

2575264 - User is Not Able to See My Contacts

Symptom

An user is not able to see any record under my contacts.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Log with affected user credentials.
  2. Go to the Accounts work center.
  3. Go to the Contacts view.
  4. Select "My Contacts" on dropdown.
  5. No record is found.

Cause

The question "Do you want to restrict access rights for contacts using Contact Team Relationship" is switched on and the restriction rule "3 - Territories" or "9 - Sales Organization of Employee" is maintained on business role as well.

If the aforementioned question is switched on, then the restriction rules 3 and 9 will not work.

Therefore, with the currently maintained configuration the user will only be authorized to see "homeless" contacts (contacts without contact team).

Resolution

This is the system expected behavior.

In order to adjust this behavior you could switch off the aforementioned question on business configuration by doing the following steps or you could change the restriction rule type on business role.

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects.
  3. Select the current project.
  4. Click on Edit Project Scope.
  5. Go to the step 4: Questions.
  6. Go to the Build-in Services and Support --> System Management -->User and Access Management.
  7. Uncheck the checkbox for question "Do you want to restrict access rights for contacts using Contact Team Relationship".
  8. Save it.

Keywords

Contact; Own; User; Restrict; Access; Homeless; Question; Restriction; Rule; Owner; , KBA , LOD-CRM-CON , Contact , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions